System Requirements

Embroidery i2 for Adobe Illustrator System Requirements

The following are the system requirement for Embroidery i2 for Adobe Illustrator and Corel Draw

For PC:
  • Adobe Illustrator CS3, CS4, CS5, CS5.1, CS6 (32 or 64-bit) or CC (32 or 64-bit). .
  • Microsoft Windows XP with Service Pack 2 or Windows 7, Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions), Windows 8, Windows 8.1, Windows 10.
  • High speed internet connection
For Mac:
  • Adobe Illustrator CS3, CS4, CS5 or CC.
  • OS X v10.4.8 - 10.5 (Leopard) or later OS, and a multi-core Intel processor.
  • High speed internet connection

Important Note for Mac users: The Embroidery i2 plug-in will not work with the Power PC chip, which was used in older Macs; and Intel-based computer is required to run the software.

If you are unsure about which chip your computer uses, you can look it up by doing the following: click the Apple symbol on the menu bar, and select About this Mac from the list. The new window that opens gives the specifics on you chip, under the heading 'Processor'. If the processor has Intel in the name, it will work with Embroidery i2.

Embroidery i2 for CorelDRAW System Requirements
  • Microsoft Windows XP with Service Pack 2 or Windows 7, Windows Vista Home Premium, Business, Ultimate, or Enterprise (certified for 32-bit editions), Windows 8, Windows 8.1, Windows 10.
  • CorelDRAW X4, X5, X6 (32-bit or 64-bit) or X7 (32-bit or 64-bit).
  • High speed internet connection
Embroidery i2 for CorelDRAW®. Click here to learn more